Skip to main content

Change of Decontamination Integration Port

Overview

The default port for the decontamination interlocking service is8060It is. If a port change is necessary depending on the client's environment, configure it according to the procedure below.


Basic Information

itemvalue
Default Port8060
Change Example8081(different depending on the environment)
Target ServiceApache Tomcat 10.1 CDR_SERVICE_UPLOAD
Service configuration file pathE:\softcamp\sanitrans\sanitrans\config\cdrbroker.properties
Tomcat configuration file pathE:\App\Tomcat_10.1_CDR_SERVICE_UPLOAD\conf\server.xml

Port Change Procedure

Step 1: Apache Tomcat 10.1 CDR_SERVICE_UPLOADserver.xmlEdit (Required)

Location of the modification file:E:\App\Tomcat_10.1_CDR_SERVICE_UPLOAD\conf\server.xml

BelowConnectorofportvalue8060in8081Changes to.

<Connector port="8081" protocol="HTTP/1.1"
connectionTimeout="20000"
URIEncoding="UTF-8" />

Step 2: Modify the service configuration file

Configuration file path:E:\softcamp\sanitrans\sanitrans\config\cdrbroker.properties

Change Items

Change the following configuration values.

# 무해화 연동 브로커 포트 변경
cdrbroker.port=8081

Step 3: Restart the Service

After changing the configuration file, restart the service in the following order.

  1. Apache Tomcat 10.1 CDR_SERVICE_UPLOAD
  2. Apache Tomcat 10.1 CDR_SERVICE_API
  3. Apache Tomcat 9.0 CDR_WEBCONSOLE
  4. SDMonitoring_Service_API

How to Restart Windows Services

# PowerShell 관리자 권한으로 실행
Restart-Service "Apache Tomcat 10.1 CDR_SERVICE_UPLOAD"
Restart-Service "Apache Tomcat 10.1 CDR_SERVICE_API"
Restart-Service "Apache Tomcat 9.0 CDR_WEBCONSOLE"
Restart-Service "SDMonitoring_Service_API"

or Windows Service Manager(services.mscManually restart in )


Configuration Validation

Normal Operation Check

  1. Check if all services have started normally
  2. Performing Decontamination Integration Testing
  3. Check Monitoring Logs

Cautions

Issues that occur if settings are not changed

Changed the port to a different value (e.g., 8081) butcdrbroker.propertiesIf not changed, the following problems will occur.

1. Monitoring Service Connection Failure

Log Check Path: E:\log\monitoring\monitoring.log

Error Log:

2026-02-09 11:01:04.891 ERROR 820 --- [main] c.s.m.c.SchedulingPropertieConfiguration : I/O error on GET request for "http://127.0.0.1:8060/v6/updateServerId/A64B2A42-99AF-CF00-29C1-366B9CCFE002": Connection refused: connect; nested exception is java.net.ConnectException: Connection refused: connect

2. Queue Processing Failure (Important)

Log Check Path: E:\log\cdrApiService\cdrApiService.log

Error Log:

2026-02-09 11:29:18.470  INFO [  http-nio-8090-exec-3] c.s.s.cloud.broker.http.WebAPIClient     : [GET] SEND start uri=http://127.0.0.1:8060/v6/queue/proc (connectTimeout=5000ms, readTimeout=15000ms) [config: defaultConnect=5000ms, defaultRead=15000ms, maxConnTotal=32, maxConnPerRoute=16]
2026-02-09 11:29:19.004 INFO [ http-nio-8090-exec-3] c.s.s.cloud.broker.http.WebAPIClient : [GET][Time taken : 534 ms] executeRequest : http://127.0.0.1:8060/v6/queue/proc
2026-02-09 11:29:19.004 ERROR [ http-nio-8090-exec-3] c.s.s.c.b.s.f.TaskNotificationService : triggerNextQueuedTask exception {}
org.apache.http.conn.HttpHostConnectException: Connect to 127.0.0.1:8060 [/127.0.0.1] failed: Connection refused: no further information
at org.apache.http.impl.conn.DefaultHttpClientConnectionOperator.connect(DefaultHttpClientConnectionOperator.java:156)

impact:

  • Decontamination integration work queue not processed
  • The task is stuck in a pending state.

Cause:

  • The actual service is running on port 8081.
  • cdrbroker.propertiesis set to the default port 8060.
  • Monitoring and API service attempted to connect on port 8060 and failed to connect.

Solution:

  1. E:\softcamp\sanitrans\sanitrans\config\cdrbroker.propertiesOpen File

  2. Change Port Settings

    cdrbroker.port=8081
  3. Restart Related Services

    • Apache Tomcat 10.1 CDR_SERVICE_UPLOAD
    • Apache Tomcat 10.1 CDR_SERVICE_API
    • Apache Tomcat 9.0 CDR_WEBCONSOLE
    • SDMonitoring_Service_API
  4. monitoring.logCheck if the error is resolved.


Notes

  • It is recommended to perform port change operations during times of low system load.
  • It is recommended to back up the current settings before making changes.
  • If firewall settings are required, additional firewall rules are needed.
  • Check if another application is using the same port.

How to Check Port Usage

# PowerShell에서 포트 사용 여부 확인
netstat -ano | findstr :8081